Home Live Radio Podcast Live TV Vodcast Forum Files Login Register :     Contact : 
 
Forum index Forum: Device: SkyTC - KMP510 (Envivo Otek Xenta Arnova) Topic: Xenta KMP 510 frozen on startup screen Last replied to: June 18, 2019, 7:51 am Back to post view
AuthorPostOptions
Posted by beelzebob Message # 1     Posted at November 3, 2011, 2:54 pm,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 1 posts
Registration date: October 30, 2011
Status: Offline

Hi,

I have a Xenta KMP510 (bought from ebay, firmware version unknown).  After a week or so it froze on the startup screen (different circles light up in turn, reaches internet radio and then stops) - turning it off, and back on again cleared it and it worked for a while longer.  A few days later it froze on displaying the startup screen (at internet radio) again; since then it won't go any further.
I have tried connecting it via USB to two different computers - neither recognises that there is a device connected (not listed in device manager or lsusb)
I have started it holding down the power button and the middle button - displays Xenta splash screen, then the circles screen and it freezes on Internet Radio)
I have started it holding down the power button and the other outside button - displays Xenta splash screen and freezes on this

Many thanks if anyone can suggest a possible fix.

Thanks and regards,
Bob.

 
Posted by benjh Message # 2     Posted at November 4, 2011, 4:06 pm,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 48 posts
Registration date: June 16, 2011
Status: Offline

Does it ever connect to the internet now? The point at which it is frozen is when it logs onto your router, I think... what does the display show bottom right? (I assume it worked just fine for the first few weeks, that it's "gone wrong", not "always been wrong".)

I have exactly  the same (Ebuyer-sourced) radio. It's firmware version 1.7 on mine, almost certainly the same on yours.

I am certainly no expert on the software, but I'll go through the startup on mine alongside yours, so we can at least get an idea of how far it is getting. I think William's excellent firmware can be forced onto the radio from boot, via the sd card slot (which I assume is empty...). I'm sure he'll correct me on that if I'm wrong (and I probably am!)

I'm guessing that, if a hardware issue, it might just be a loose/faulty wifi dongle, and it's booting that far, trying/failing to connect to the internet, and getting stuck. S'pose you haven't altered any settings on the router in that time? (It might just be worth dropping all security on the router, and seeing if it connects...)

I can dig mine out, and post exactly what happens to mine after yours gets stuck!

Ben

(Last Edited by benjh on November 4, 2011, 4:08 pm)
 
Posted by penbex Message # 3     Posted at November 4, 2011, 5:47 pm,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 2282 posts
Registration date: May 21, 2009
Status: Offline

I should be able to fix it if it is just a firmware issue.

If there is a hardware issue (dead chips, smoke coming out of it etc.) then there is not much I can do either.

I have send you an email.

William

 
Posted by staintona Message # 4     Posted at November 15, 2011, 3:51 pm,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 2 posts
Registration date: November 15, 2011
Status: Offline

Quote:

I should be able to fix it if it is just a firmware issue.

If there is a hardware issue (dead chips, smoke coming out of it etc.) then there is not much I can do either.

I have send you an email.

 

 

I have just posted on the Ebuyer Forum and then found this one, so the question is on both.

My Xenta media player (I suspect KMP510) also freezes at the boot screen on Internet radio. I can see no way of resetting to factory defaults or accessing the firmware, as it does not display as a storage device in Linux or Windows. There is no physical damage of which I am aware, so i was hoping you may have a suggestion?

Thanks in advance

Adrian


(Last Edited by staintona on November 15, 2011, 3:52 pm)
 
Posted by penbex Message # 5     Posted at November 16, 2011, 12:50 pm,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 2282 posts
Registration date: May 21, 2009
Status: Offline

I am currently checking out a box with a similar problem.
Initial tests indicate that most of the flash memory is erased.
Both the regular boot mode and the recovery mode are gone.
I hope to learn some more things from this box and perhaps find a way to fix it.

Everyone with such a box should first check if they do nto have any warranty left on the device.
If not, then the only thing you can do for now is wait until I am done with digging through the memory and trying to repair it.

William

 

 

 
Posted by benjh Message # 6     Posted at November 16, 2011, 6:42 pm,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 48 posts
Registration date: June 16, 2011
Status: Offline

For those tempted to do a return, Xenta is an Ebuyer-own-label, as far as I can tell. It's out of stock, and they have told me they aren't getting any more, so you'll get a refund, not a replacement.

Ebuyer's returns online system works well, and once you've raised an RMA, you have 28 days to get the device in... so if you are about to run out of warranty, get the RMA now, then wait & see if William does something clever.

If you are about to come up to the six-month period of ownership, it might be worth getting the RMA done before the end of the sixth month, as the burden of proof shifts from them having to accept there was a fault when you got it, to the lesser of it just developing a fault. Shouldn't matter, but...

If you do get an RMA, you can let it expire, and then just get another one...

Ebuyer does come in for some stick, but they've always done well with returns for me & most of my friends.


On another point, and I'm being so, so, so naive here....
... can't I just make a disk image of my working one, and that be squirted onto your dead ones? ok, ok.... thus proving I know nowt about nowt... I'll get me coat....


(William - I've updated mine to your firmware, but if you want any files off it, let me know! You might email me, as I might not notice this thread for a day or so)

Ben H

(Last Edited by benjh on November 16, 2011, 6:43 pm)
 
Posted by djbobw Message # 7     Posted at November 18, 2011, 9:00 am,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 13 posts
Registration date: June 6, 2011
Status: Offline

I've had to return my Xenta for a refund, with the hope of picking one up elsewhere. I've found them (under a different name) but I'm not willing to pay out £120 for one, especially when the Xenta cost under £50.

Unfortunately I think this may be the end for these devices for me, as I'm not willing to pay that much for a device that has already failed on me once. With eBuyer I knew returning it would be easy, sellers on eBay and Amazon may not be so easy.

 
Posted by penbex Message # 8     Posted at November 18, 2011, 1:26 pm,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 2282 posts
Registration date: May 21, 2009
Status: Offline

http://www.redcoon.es/B293370-Foxman-Internet-TV_TV-LCD
New, 49 euros. No idea yet about shipping but the company seems to operate in many countries.

 

 
Posted by benjh Message # 9     Posted at November 18, 2011, 2:38 pm,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 48 posts
Registration date: June 16, 2011
Status: Offline

http://www.pearl.de/a-PX8595-1606.shtml

More expensive, also available in other countries. Haven't seen any cheap ones in theUK for a while.... Having a poke round now over a late lunch!
 
Posted by staintona Message # 10     Posted at November 20, 2011, 10:24 am,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 2 posts
Registration date: November 15, 2011
Status: Offline

Hi, my xenta unit is out of warranty, so looks like either a new one or some way of renewing the flash memory.  I don't know whether it's a trade secret but how can the flash memory actually be accessed? The USB connection does not respond at all, so would modifying the flash require some kind of specialist tools or am I also showing my complete ignorance here and the flash memory cannot be altered/modified anyway?

 

 

 
Posted by pihnat Message # 11     Posted at November 13, 2012, 11:39 am,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 1 posts
Registration date: August 22, 2012
Status: Offline


I've got an Otek IPTV510 which has been having the same fault as the one described in the original post - at switchon the different circles light up in turn and then freezes on the internet radio symbol.

The problem until now has been intermittent and when it freezes I could unplug the power and re-start and it would run OK. This has occurred with ver 1.43 and now 1.44 of the firmware. I don't know if it had this problem with the original firmware since I didn't run it too many times before I upgraded to Listenlive.

Now the problem is permanent - it won't go past the internet radio symbol. It doesn't matter if the SD card is plugged in or not.

Does anyone know what the unit is actually doing straight after it lights the internet radio symbol? Is it checking something eg hardware before continuing?

Thanks for any help
Peter
 
 
Posted by penbex Message # 12     Posted at November 13, 2012, 1:03 pm,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 2282 posts
Registration date: May 21, 2009
Status: Offline

send an email
 
Posted by chris24747 Message # 13     Posted at June 22, 2013, 11:14 pm,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 1 posts
Registration date: June 22, 2013
Status: Offline

Hello,

   Did you manage to find a solution to the freezing at startup issue at all? Mine goes through the flashing icons and then to a blank screen and does nothing.
My Xenta has been sat in the back of a drawer for 18 months and i have just dug it out hoping for a solution.

Any ideas? Otherwise i think it may time for the bin

Thanks in advance
 
Posted by penbex Message # 14     Posted at June 23, 2013, 1:26 pm,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 2282 posts
Registration date: May 21, 2009
Status: Offline

Yes, it can be fixed. contact me for details
 
Posted by bogster Message # 15     Posted at April 23, 2019, 5:41 pm,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 1 posts
Registration date: April 23, 2019
Status: Offline

i know this is a long long long shot but did anyone find a fix for this problem. My kmp510 has just started doing the same thing.

thanks in advance.
 
Posted by penbex Message # 16     Posted at April 24, 2019, 1:52 pm,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 2282 posts
Registration date: May 21, 2009
Status: Offline

Although it can be fixed it takes a fair bit of time.
You need a bunch of images/software and a lot of trail and error to get it fixed. 
A working device that you can dump might help a bit.
Spending 3 or more hours on it is simply too much for this kind and quality of device.






 
Posted by deviousrich Message # 17     Posted at June 17, 2019, 7:18 am,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 3 posts
Registration date: June 17, 2019
Status: Offline

hi,

i appreciate this is an old post, but just to say i have exactly the same, an old Xenta unit, boots up but then freezes at the "internet Radio" button on screen and doesnt react to any button presses or remote control (except the power button).
i can however access the storage via USB but i dont think that helps me as i cant force it to boot into the new firmware image from what i can tell?

i wonder if this is one of the instances of the timebomb bad blocks showing up on the Xenta branded units?


 
Posted by penbex Message # 18     Posted at June 17, 2019, 8:36 am,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 2282 posts
Registration date: May 21, 2009
Status: Offline

Yes, the main firmware image is corrupted and the boot process cant complete.

 
Posted by deviousrich Message # 19     Posted at June 17, 2019, 2:32 pm,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 3 posts
Registration date: June 17, 2019
Status: Offline

thats what i thought, thanks for confirming. I assume from reading around this means its fit only for the bin?
 
Posted by penbex Message # 20     Posted at June 17, 2019, 4:09 pm,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 2282 posts
Registration date: May 21, 2009
Status: Offline

With the right skills it might be possible to revive it.
however, since the corruption is random, this depends largely on what was damaged.. 
Sometimes it is just a config file, then a work around is possible and it will work for a while again.
Other times boot, kernal or other critical part is damaged and it will be very difficult to fix it then.
I used to fix them in the past for people.. but the device is not expensive enough to spend 4 or more hours on it.


 
Posted by deviousrich Message # 21     Posted at June 18, 2019, 7:51 am,     subject: Xenta KMP 510 frozen on startup screen  
Messages: 3 posts
Registration date: June 17, 2019
Status: Offline

thats what i suspected, not to worry it was only an idea. thanks for hosting a great community website!